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Motivation: Real exchange rate in the long-run
‣Determinants of Real Exchange Rate (RER) in the long-run
‣ Textbook: Balassa-Samuelson (BS)
‣ If relative productivity of tradable to non-tradable ↑, then RER ↑
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Refresher: Textbook Balassa-Samuelson
Country  , Sector  , fixed labor endowment: 

Production  

Sectoral price 

LOOP:   wages   

Cobb-Douglas across sectors  CPI: 

Real exchange rate: relative productivity

i, j s = T, N Li = ∑ ℓi,s

Yi,s = Ai,s ⋅ ℓi,s

Pi,s = wi/Ai,s

Pi,T = Pj,T → wi/wj = Ai,T /Aj,T →
Pi,N

Pj,N
=

Ai,T /Aj,T

Ai,N /Aj,N

→ Pi = Pαi,T
i,T ⋅ Pαi,N

i,N

RERi,j =
Pi

Pj
= (Ai,T /Ai,N)αi,N

(Aj,T /Aj,N)
αj,N
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29

Motivation: Real exchange rate in the long-run
‣Determinants of Real Exchange Rate (RER) in the long-run
‣ Textbook: Balassa-Samuelson (BS)
‣ If relative productivity of tradable to non-tradable ↑, then RER ↑

What we know (?)
‣ Empirical literature: Mixed
‣ Different periods / countries / specifications → different results
‣ Controlling for wages is a ``bad control’’, testing “Residualized?” BS

‣ Quantitative literature: Mixed
‣ All are short-run business-cycle models—not for long-run effects
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Research Questions and My Answers
‣ Can BS qualitatively explain the long-run RER? - Yes
‣ Show that traditional specifications are not robust and are ``inconsistent’’
‣ Adding time FEs resolves the inconsistency and leads to robust results
‣ Qualitatively, BS is right on average

‣ Can BS quantitatively explain long-run RER - No
‣ Set up multiple versions of quantitative trade models
‣ Costly trade, N-country, IO linkages, S-sector

‣ Quantitatively, BS cannot explain RER (effects are close to zero)
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Today’s plan

1. Qualitative validity

2. Quantitative (un)importance

3. Reasons for the failure of the model?
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Traditional empirical design
‣ Traditional empirical design

‣  : reference country (typically the US);  : country FEs

‣ Mixed Findings from previous papers (different year/country/data): 
‣  : Officer (1976), Hsieh (1982), Lee and Tang (2007), Cardi and Restout 

(2015)
‣  : Canzoneri et al (1999), Berka-Devereux-Engel (2018), Berka and 

Steenkamp (2018), Devereux-Fujiwara-Granados (2025),…

ln RERi,j,t = β ln (
Ai,T,t /Ai,NT,t

AU,T,t /AU,NT,t ) + μi + εi,t

U μi

✓

×
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Data 
‣ RER: Penn World Table
‣ CPI (``pl_c’’) and Nominal exchange rate

‣ Labor productivity: real value added per hour from KLEMS
‣ EU KLEMS (Europe, US, Japan) — baseline, balanced panel sample
‣ Asia KLEMS (Korea, Taiwan, India)
‣ CIP from RIETI (China)

‣ Years: 1970-2021 (or 1995-2021)

‣ HP-filtered ( , Ravn and Uhlig (2002))λ = 6.25
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Real exchange rate and relative productivity 

9



29

Results differs across reference countries
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Econometric issues of traditional approach
‣ Traditional approach requires  (  alone is not enough)
‣  is a typical consistency assumption in panel-data analyses

‣ Reference-country-specific errors do not wash out as 
‣ ``US enters the regression  times, while others enter  times’’

T → ∞ N → ∞
N → ∞

N → ∞
NT T

ln RERi,j,t = β ln (
Ai,T,t /Ai,NT,t

AU,T,t /AU,NT,t ) + μi + εi,t
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Easy Fix: Including Time Fixed Effects
‣ Easy fix: include Time FEs

‣ Variations are across non-reference countries

‣ Do not mix up two different sources of variations
‣ US-UK, US-Japan, US-Germany  give up! (Or run pair-level)
‣ UK-Japan, Japan-Germany, Germany-UK  focus on these

ln RERi,j = β ln (
Ai,T,t /Ai,NT,t

AU,T,t /AU,NT,t ) + μi + ηt + εi,t

→
→
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Robust results across reference countries
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Robust results across different settings
‣ Previous papers: Mixed results across different settings

‣ My specification is robust across
‣ Different years (1970-2021, 1995-2021, etc)
‣ Different frequencies (1, 5, 10, 20 years)
‣ Different country sets (Only EU, Adv, Balanced, Dev. countries)
‣ Different data (10 sector DB, instead of KLEMS) 
‣ Different productivity measure (VA per workers, Composition adjusted)
‣ Different covariates (GDP per workers = Penn Effect)
‣ Different RER measures (BIS’s REER)
‣ Different filtering (Christiano–Fitzgerald, no filtering,..)
‣ Different NT shares (by pairwise design) 14



29

Summary of empirical validity
‣ Traditional Specifications are not robust
‣ The issue comes from single-reference without time FEs
‣ Not consistent even with 

‣ Including time fixed effects leads to robust results

‣ Balassa-Samuelson Effects are qualitatively (empirically) present

N → ∞
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Today’s plan

1. Qualitative validity

2. Quantitative (un)importance

3. Reasons for the failure of the model?
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Quantitative accounting
‣ Goal: Quantitatively evaluate how much productivity can explain RER

‣ Variants of textbook trade models
‣ 2x2 Free Trade, 2x2, Nx2, NxS, NxSxS (IO linkages)
‣ Break LOOP (= Costly Trade)

‣ Similar spirit to Davis-Weinstein (2001 AER) for Heckscher-Ohlin-Vanek

‣ Calibrate the model to 2000 (Exact Hat Algebra)
‣ Shock the economy by feeding sectoral productivity 

‣ Later add shocks to trade costs, total labor, and deficits as well
‣ Focus on 31 countries with non-missing data (= Europe, US, Japan, China)

‣ Evaluate changes of REER between 2000-2019 against data

{Ai,s,t}
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2x2 free trade model cannot explain long-run RER

18

Change in REER in Data and 2x2 Free Trade Model 
2000=1, HP-filtered ( 6.25)λ =
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Costly trade does not help

19

‣ Textbook model
‣ Free trade in Tradables/MFG
‣ No trade in Non-tradables/Service

‣ Reality
‣ LOOP does not hold in MFG
‣ Rises of Service trade

‣ 2x2 Costly Trade
‣ Allow both sectors to costly trade

Changes in REER: 2x2 Costly Trade Model 
2000 = 1, HP-filtered ( 6.25)λ =



29

Extending to N countries does not help
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‣ 2x2 (Costly/Free) Trade Model
‣ Solve 2x2 models (Nx(N-1))2 times
‣ Asm. no China effect on JPY-USD 

‣ Reality
‣ We have N countries

‣ Matsuyama (2009, JEEA)

‣ N (31) x2 Costly Trade Model
‣ KLEMS countries + ROW

Changes in REER: Nx2 Costly Trade Model 
2000 = 1, HP-filtered ( 6.25)λ =



29

Richer models with more shocks do not help

21

‣ Nx2 Trade Model
‣ No Input-Output linkages
‣ 2 sector (distinctions matter)

‣ NxS (31x23) with IO linkages

Changes in REER: NxS Costly Trade Model w/ IO 
2000 = 1, HP-filtered ( 6.25)λ =
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Summary of REER results
‣ Textbook 2x2 Free Trade model is the least problematic

‣ N country, S sector, IO linkages (+ other bells and whistles) worsens the fit

‣ Seemingly, standard quantitative trade models cannot account for
‣ Changes in real exchange rates (= prices) across countries
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Today’s plan

1. Qualitative validity

2. Quantitative (un)importance

3. Reasons for the failure of the model?
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Where do we fail: Goods REER are off in Costly Trade

24

Change in Service REER  
2000 = 1, Nx2 Costly Trade

Change in Goods REER  
2000 = 1, Nx2 Costly Trade
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High Productivity, High Price (Data), Low Price (Model)
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Observed Data Nx2 Costly Trade Model

Change in Goods REER against Productivity; 2000 = 1
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Discussion: Sources of failures

Measuring Shocks
• Productivity
• Trade costs
• Total labor endow.
• Trade deficits

26

Models
• Input: Shocks
• Output: Wages

Price Aggregator
• Input: Wages (+ data )
• Outputs:

• Sectoral PPI/CPI
• CPI
• RER

π

Engel (1999): pS - RER

Next:
1. Feeding observed changes in wages (in national currency)
2. Check sectoral RER (using Nx2 model) and aggregate RER
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Feeding wages replicate sectoral RERs
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Change in Service REER  
2000 = 1, Nx2 Costly Trade + Wage

Change in Goods REER  
2000 = 1, Nx2 Costly Trade + Wage
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Discussion: Sources of the quantitative failure of BS
‣ Goods REER are particularly off
‣ (Unobserved) quality upgrading within sector?

‣ Given observed wages, REER fits well
‣ Wage responses (to productivity) are too small?

‣ Traditional candidates as a source of the failure of Balassa-Samuelson
‣ Breakdown of LOOP — maybe not b/c Relaxing LOOP worsens!
‣ Changing tradability — maybe not
‣ Mechanical weight changes— b/c aggregator worked with fixed shares
‣ Structural reasons — b/c changing trade costs did not help

‣ Inability of macro/trade model to replicate wage changes — maybe.
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Conclusion
‣ Testing Balassa-Samuelson qualitatively and quantitatively 

‣ Qualitatively, BS is supported
‣ Traditional approach, yielding mixed results, had econometrics issues
‣ Time fixed effects resolve the issue

‣ Quantitatively, BS performs poorly
‣ Richer models do not help
‣ Failures might come from the inability of the models to explain wages
‣ Productivity measurement? Price measurement? — quality, “appeal”
‣ Markdown? 29
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Japanese MFG’s Relative Productivity Grow Faster

31
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Econometric issues of traditional approach 1/2

DGP for CPI:  

In ``relative’’ to reference country , 

Then,  

Leading to the traditional specification

Within-estimator:  and 

ln Pi,t = β ai,t + αi + gt + ui,t, ai,t ≡ ln( Ai,T,t

Ai,NT,t )
U

ri,t ≡ ln RERi,U,t = ln( Pi,t

PU,t ) = ln Pi,t − ln PU,t, i ≠ U

ri,t = β(ai,t − aU,t) + (αi − αU) + (ui,t − uU,t),

ri,t = βxi,t + μi + εi,t

r̃i,t = β x̃i,t + ε̃i,t

̂β = β +
Sxε

Sxx
, Sxε ≡ ∑

i,t

x̃i,tε̃i,t, Sxx ≡ ∑
i,t

x̃ 2
i,t .
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Econometric issues of traditional approach 2/2
Error terms:

However, even under standard exogeneity,

Sxε = ∑
i,t

(ai,t − āi)(ui,t − ūi) − ∑
i,t

(ai,t − āi)(uU,t − ūU)

−∑
i,t

(aU,t − āU)(ui,t − ūi) + N∑
t

(aU,t − āU)(uU,t − ūU)

Sxx = ∑
i,t

(ai,t − āi)2 + N∑
t

(aU,t − āU)2 + cross terms .

̂β − β =
Sxε

Sxx
=

Op(N T)
Op(NT)

+ op(1) = Op( 1

T ),
33
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Robust results after controlling Penn effects

34
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Robust results with different data and variables 
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Overview of quantitative model
‣ Goal: Quantitatively evaluate how much productivity can explain RER
‣ Vehicles: Variants of textbook trade models
‣ 2x2 Free Trade, 2x2 Costly Trade, Nx2 Costly Trade (+ IO linkages)

‣ Country:  ; Sector: 
‣ All prices are expressed in USD (nominal)

‣ Textbook Armington Trade Model
‣ Preferences: Cobb-Douglas across sectors, CES within sectors
‣ Technology: linear in labor
‣ Market clearing: exogenous trade surplus

i, j = 1,..,N s = 1,2
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Preference: (Armington Trade)
Cobb-Douglas across sectors

CES within sectors

Uj =
S

∏
s=1 (

Cj,s

αj,s )
αj,s

Cj,s = (
N

∑
i=1

μ1/θ
i,j,sC

(θ−1)/θ
i,j,s )

θ/(θ−1)

37

Aggregate CPI

Sectoral CPI and Trade Share

Pj =
S

∏
s=1

Pαj,s
j,s

Pj,s = (
N

∑
i=1

μi,j,sP 1−θ
i,j,s )

1/(1−θ)

πi,j,s ≡
Pi,j,sCi,j,s

∑N
ℓ=1 Pℓ,j,sCℓ,j,s

=
μi,j,sP 1−θ

i,j,s

∑N
ℓ=1 μℓ,j,sP 1−θ

ℓ,j,s
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Technology and trade
Linear Production in Labor

Unit production cost

Costly trade

Yi,s = Ai,s ⋅ ℓi,s, Li = ∑
s

ℓi,s

ci,s =
wi

Ai,s

Pi,j,s = τi,j,s ⋅ ci,s =
wi ⋅ τi,j,s

Ai,s
38
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Equilibrium
An equilibrium is  s.t.

Goods markets clear ( )

where trade share is given by

{wi}i∈𝒩

∑
i

βi = 0

N

∑
j=1

S

∑
s=1

πi,j,s ⋅ αj,s ⋅ wjLj = wiLi + βi ⋅
N

∑
ℓ=1

wℓLℓ

πi,j,s =
μi,j,s ( wiτi,j,s

Ai,s )
1−θ

∑N
ℓ=1 μℓ,j,s ( wℓτℓ,j,s

Aℓ,s )
1−θ
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Wage to Price

Price to Aggregate CPI
CES + Cobb-Douglas

Real Exchange Rate

Pi,j,s =
wi ⋅ τi,j,s

Ai,s

RERi,j =
Pi

Pj



30
40



30
41


